summaryrefslogtreecommitdiffstats
path: root/devlink/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--devlink/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/devlink/Makefile b/devlink/Makefile
new file mode 100644
index 0000000..1a1eed7
--- /dev/null
+++ b/devlink/Makefile
@@ -0,0 +1,19 @@
+# SPDX-License-Identifier: GPL-2.0
+include ../config.mk
+
+DEVLINKOBJ = devlink.o mnlg.o
+TARGETS += devlink
+LDLIBS += -lm
+
+all: $(TARGETS) $(LIBS)
+
+devlink: $(DEVLINKOBJ) $(LIBNETLINK)
+ $(QUIET_LINK)$(CC) $^ $(LDFLAGS) $(LDLIBS) -o $@
+
+install: all
+ for i in $(TARGETS); \
+ do install -m 0755 $$i $(DESTDIR)$(SBINDIR); \
+ done
+
+clean:
+ rm -f $(DEVLINKOBJ) $(TARGETS)