summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..9636311
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,25 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+export DEB_CFLAGS_MAINT_APPEND = -Werror=implicit-function-declaration
+include /usr/share/dpkg/pkg-info.mk
+include /usr/share/dpkg/architecture.mk
+
+ifeq (,$(findstring terse,$(DEB_BUILD_OPTIONS)))
+ VERBOSE=1
+endif
+
+%:
+ dh $@ --sourcedirectory=src
+
+override_dh_gencontrol:
+ dh_gencontrol -- -v1:$(DEB_VERSION)
+
+override_dh_makeshlibs:
+ dh_makeshlibs -- -v1:$(DEB_VERSION)
+
+override_dh_auto_build:
+ dh_auto_build -- LIBSUBDIR=lib/$(DEB_HOST_MULTIARCH) V=$(VERBOSE)
+
+override_dh_auto_install:
+ dh_auto_install -- LIBSUBDIR=lib/$(DEB_HOST_MULTIARCH) V=$(VERBOSE)