summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:23:06 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:23:06 +0000
commitf0a36d8c584c05e42cc298844ca061306fa6c27e (patch)
tree8e69dfebe15c25d02792eb6097975cd5e63b63f1 /debian/rules
parentAdding upstream version 1.12.0. (diff)
downloadlibfido2-f0a36d8c584c05e42cc298844ca061306fa6c27e.tar.xz
libfido2-f0a36d8c584c05e42cc298844ca061306fa6c27e.zip
Adding debian version 1.12.0-2.debian/1.12.0-2debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..b6d5fec
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- -DUDEV_RULES_DIR=/lib/udev/rules.d \
+ -DCMAKE_BUILD_RPATH_USE_ORIGIN=ON
+
+override_dh_makeshlibs:
+ dh_makeshlibs -- -c4
+
+override_dh_auto_test:
+ debian/run-regression-tests.sh