summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-11-19 17:00:27 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-11-19 17:00:27 +0000
commit1ccae06e05bf507a314db2c8246ce27f96ecfef8 (patch)
treeb52c103fc24ee791bb2c716cbe8438efa3a40e95
parentReleasing progress-linux version 6.3.0-1~progress6+u1. (diff)
downloadlibphp-swiftmailer-1ccae06e05bf507a314db2c8246ce27f96ecfef8.tar.xz
libphp-swiftmailer-1ccae06e05bf507a314db2c8246ce27f96ecfef8.zip
Merging debian version 6.3.0-2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rw-r--r--debian/patches/0002-Handle-the-case-of-missing-DES-ECB-cipher-support.patch40
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/tests/phpunit2
5 files changed, 51 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 39c2ac0..3c47fe0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+libphp-swiftmailer (6.3.0-2) unstable; urgency=medium
+
+ * Fix printing of commands in autopkgtests
+ * Bump Standards-Version, no changes
+ * Handle the case of missing DES-ECB cipher support (Closes: #1011781)
+
+ -- Robin Gustafsson <robin@rgson.se> Sat, 28 May 2022 20:52:45 +0200
+
libphp-swiftmailer (6.3.0-1~progress6+u1) fuchur-backports; urgency=medium
* Initial upload to fuchur-backports.
diff --git a/debian/control b/debian/control
index 304f6f0..ac13173 100644
--- a/debian/control
+++ b/debian/control
@@ -16,7 +16,7 @@ Build-Depends:
phpunit <!nocheck>,
php-email-validator <!nocheck>,
pkg-php-tools,
-Standards-Version: 4.6.0
+Standards-Version: 4.6.1
Homepage: https://swiftmailer.symfony.com/
Vcs-Browser: https://git.progress-linux.org/packages/fuchur-backports/libphp-swiftmailer
Vcs-Git: https://git.progress-linux.org/packages/fuchur-backports/libphp-swiftmailer
diff --git a/debian/patches/0002-Handle-the-case-of-missing-DES-ECB-cipher-support.patch b/debian/patches/0002-Handle-the-case-of-missing-DES-ECB-cipher-support.patch
new file mode 100644
index 0000000..d5d7360
--- /dev/null
+++ b/debian/patches/0002-Handle-the-case-of-missing-DES-ECB-cipher-support.patch
@@ -0,0 +1,40 @@
+From: Robin Gustafsson <robin@rgson.se>
+Date: Sat, 28 May 2022 20:39:10 +0200
+Subject: Handle the case of missing DES-ECB cipher support
+
+One feature requires the DES-ECB cipher from the OpenSSL extension,
+which is nowadays deemed insecure and thus no longer supported.
+---
+ lib/classes/Swift/Transport/Esmtp/Auth/NTLMAuthenticator.php | 3 +++
+ tests/unit/Swift/Transport/Esmtp/Auth/NTLMAuthenticatorTest.php | 4 ++++
+ 2 files changed, 7 insertions(+)
+
+diff --git a/lib/classes/Swift/Transport/Esmtp/Auth/NTLMAuthenticator.php b/lib/classes/Swift/Transport/Esmtp/Auth/NTLMAuthenticator.php
+index 41931fd..d62639f 100644
+--- a/lib/classes/Swift/Transport/Esmtp/Auth/NTLMAuthenticator.php
++++ b/lib/classes/Swift/Transport/Esmtp/Auth/NTLMAuthenticator.php
+@@ -549,6 +549,9 @@ class Swift_Transport_Esmtp_Auth_NTLMAuthenticator implements Swift_Transport_Es
+ */
+ protected function desEncrypt($value, $key)
+ {
++ if (!in_array('des-ecb', openssl_get_cipher_methods())) {
++ throw new LogicException('The OpenSSL extension must provide the DES-ECB cipher to use certain features of the NTLM authenticator.');
++ }
+ return substr(openssl_encrypt($value, 'DES-ECB', $key, \OPENSSL_RAW_DATA), 0, 8);
+ }
+
+diff --git a/tests/unit/Swift/Transport/Esmtp/Auth/NTLMAuthenticatorTest.php b/tests/unit/Swift/Transport/Esmtp/Auth/NTLMAuthenticatorTest.php
+index 2337149..96c94d7 100644
+--- a/tests/unit/Swift/Transport/Esmtp/Auth/NTLMAuthenticatorTest.php
++++ b/tests/unit/Swift/Transport/Esmtp/Auth/NTLMAuthenticatorTest.php
+@@ -29,6 +29,10 @@ class Swift_Transport_Esmtp_Auth_NTLMAuthenticatorTest extends \SwiftMailerTestC
+
+ public function testLMv1Generator()
+ {
++ if (!in_array('des-ecb', openssl_get_cipher_methods())) {
++ $this->markTestSkipped('Need OpenSSL extension with the DES-ECB cipher to run this test.');
++ }
++
+ $password = 'test1234';
+ $challenge = 'b019d38bad875c9d';
+ $lmv1 = '1879f60127f8a877022132ec221bcbf3ca016a9f76095606';
diff --git a/debian/patches/series b/debian/patches/series
index 40cf12b..f86d539 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
0001-Fix-PHPUnit-method-signatures.patch
+0002-Handle-the-case-of-missing-DES-ECB-cipher-support.patch
diff --git a/debian/tests/phpunit b/debian/tests/phpunit
index 8613b23..f787cc0 100755
--- a/debian/tests/phpunit
+++ b/debian/tests/phpunit
@@ -1,5 +1,5 @@
#!/bin/sh
-set +x
+set -x
mkdir -p vendor
cp debian/autoload.test.php vendor/autoload.php