summaryrefslogtreecommitdiffstats
path: root/doxygen/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:54:46 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:54:46 +0000
commitcd7b005519ade8ab6c97fcb21590b71b7d1be6e3 (patch)
treec611a8d0cd5e8f68f41b8c2d16ba580e0f40a38d /doxygen/examples/CMakeLists.txt
parentInitial commit. (diff)
downloadlibrtr-cd7b005519ade8ab6c97fcb21590b71b7d1be6e3.tar.xz
librtr-cd7b005519ade8ab6c97fcb21590b71b7d1be6e3.zip
Adding upstream version 0.8.0.upstream/0.8.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'doxygen/examples/CMakeLists.txt')
-rw-r--r--doxygen/examples/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/doxygen/examples/CMakeLists.txt b/doxygen/examples/CMakeLists.txt
new file mode 100644
index 0000000..b58f7bf
--- /dev/null
+++ b/doxygen/examples/CMakeLists.txt
@@ -0,0 +1,8 @@
+if(CMAKE_BUILD_TYPE STREQUAL Debug)
+ if(RTRLIB_HAVE_LIBSSH)
+ add_executable(rtr_mgr rtr_mgr.c)
+ target_link_libraries(rtr_mgr rtrlib)
+ add_executable(ssh_tr ssh_tr.c)
+ target_link_libraries(ssh_tr rtrlib_static)
+ endif(RTRLIB_HAVE_LIBSSH)
+endif(CMAKE_BUILD_TYPE STREQUAL Debug)