summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 07:26:16 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 07:26:16 +0000
commitacdb9c14da22fa018b848e74e6b3505308232c9d (patch)
treea8886de45de94c715609a00ceef7bde7c0a1b2e3 /debian/rules
parentAdding upstream version 1.6.4. (diff)
downloadlibtracefs-acdb9c14da22fa018b848e74e6b3505308232c9d.tar.xz
libtracefs-acdb9c14da22fa018b848e74e6b3505308232c9d.zip
Adding debian version 1.6.4-1.debian/1.6.4-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..9aa1a72
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+
+include /usr/share/dpkg/architecture.mk
+DPKG_EXPORT_BUILDTOOLS=1
+-include /usr/share/dpkg/buildtools.mk
+
+ifeq (,$(findstring terse,$(DEB_BUILD_OPTIONS)))
+ VERBOSE=1
+endif
+
+PREFIX=/usr
+build_flags = prefix=$(PREFIX) libdir_relative=lib/$(DEB_HOST_MULTIARCH) pkgconfig_dir=$(PREFIX)/lib/$(DEB_HOST_MULTIARCH)/pkgconfig V=$(VERBOSE)
+
+%:
+ dh $@ --no-parallel
+
+override_dh_auto_build:
+ dh_auto_build -- all doc $(build_flags)
+
+override_dh_auto_install:
+ dh_auto_install -- install_doc $(build_flags)