summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:55:11 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:55:11 +0000
commit8712cf23f0ebf5323f546a6b6363a27d12461b2d (patch)
treeaa6828b07e325da484988c86c36cba4e78a10629 /debian/rules
parentAdding upstream version 2.1.30. (diff)
downloadlibyang2-8712cf23f0ebf5323f546a6b6363a27d12461b2d.tar.xz
libyang2-8712cf23f0ebf5323f546a6b6363a27d12461b2d.zip
Adding debian version 2.1.30-2.debian/2.1.30-2debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f64035d
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+#export DH_VERBOSE=1
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+include /usr/share/dpkg/default.mk
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ -DCMAKE_BUILD_TYPE:String="Release" \
+ -DENABLE_TESTS=ON