summaryrefslogtreecommitdiffstats
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:55:11 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:55:11 +0000
commitcd07912073c951b4bbb871ed2653af1be2cfc714 (patch)
tree1073c2308492e6aea4c66cb7436ee92db2abfd42 /tools/CMakeLists.txt
parentInitial commit. (diff)
downloadlibyang2-upstream/2.1.30.tar.xz
libyang2-upstream/2.1.30.zip
Adding upstream version 2.1.30.upstream/2.1.30upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--tools/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
new file mode 100644
index 0000000..b92f80c
--- /dev/null
+++ b/tools/CMakeLists.txt
@@ -0,0 +1,15 @@
+# config file for tools
+configure_file(${PROJECT_SOURCE_DIR}/tools/config.h.in ${PROJECT_BINARY_DIR}/tools/config.h @ONLY)
+
+if(WIN32)
+ find_library(GETOPT_LIBRARY NAMES getopt REQUIRED)
+ find_path(GETOPT_INCLUDE_DIR NAMES getopt.h REQUIRED)
+ message(STATUS "Found <getopt.h> at ${GETOPT_INCLUDE_DIR}, library at ${GETOPT_LIBRARY}")
+endif()
+
+add_subdirectory(lint)
+add_subdirectory(re)
+
+set(format_sources
+ ${format_sources}
+ PARENT_SCOPE)