summaryrefslogtreecommitdiffstats
path: root/src/base/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 17:44:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 17:44:55 +0000
commit5068d34c08f951a7ea6257d305a1627b09a95817 (patch)
tree08213e2be853396a3b07ce15dbe222644dcd9a89 /src/base/CMakeLists.txt
parentInitial commit. (diff)
downloadlnav-5068d34c08f951a7ea6257d305a1627b09a95817.tar.xz
lnav-5068d34c08f951a7ea6257d305a1627b09a95817.zip
Adding upstream version 0.11.1.upstream/0.11.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/base/CMakeLists.txt')
-rw-r--r--src/base/CMakeLists.txt83
1 files changed, 83 insertions, 0 deletions
diff --git a/src/base/CMakeLists.txt b/src/base/CMakeLists.txt
new file mode 100644
index 0000000..aa4143f
--- /dev/null
+++ b/src/base/CMakeLists.txt
@@ -0,0 +1,83 @@
+add_library(
+ base STATIC
+ ../config.h.in
+ ansi_scrubber.cc
+ attr_line.cc
+ attr_line.builder.cc
+ auto_pid.cc
+ date_time_scanner.cc
+ fs_util.cc
+ humanize.cc
+ humanize.network.cc
+ humanize.time.cc
+ intern_string.cc
+ is_utf8.cc
+ isc.cc
+ lnav.console.cc
+ lnav.gzip.cc
+ lnav_log.cc
+ network.tcp.cc
+ paths.cc
+ snippet_highlighters.cc
+ string_attr_type.cc
+ string_util.cc
+ strnatcmp.c
+ time_util.cc
+
+ ansi_scrubber.hh
+ attr_line.hh
+ attr_line.builder.hh
+ auto_fd.hh
+ auto_mem.hh
+ auto_pid.hh
+ bus.hh
+ date_time_scanner.hh
+ enum_util.hh
+ fs_util.hh
+ func_util.hh
+ future_util.hh
+ humanize.hh
+ humanize.network.hh
+ humanize.time.hh
+ injector.hh
+ injector.bind.hh
+ intern_string.hh
+ is_utf8.hh
+ isc.hh
+ itertools.hh
+ lnav.console.hh
+ lnav.console.into.hh
+ log_level_enum.hh
+ lrucache.hpp
+ math_util.hh
+ network.tcp.hh
+ paths.hh
+ result.h
+ snippet_highlighters.hh
+ string_attr_type.hh
+ strnatcmp.h
+ time_util.hh
+
+ ../third-party/xxHash/xxhash.h
+ ../third-party/xxHash/xxhash.c
+)
+
+target_include_directories(base PUBLIC . .. ../third-party
+ ${CMAKE_CURRENT_BINARY_DIR}/..)
+target_link_libraries(base cppfmt cppscnlib pcrepp ncurses::libcurses pthread)
+
+add_executable(
+ test_base
+ attr_line.tests.cc
+ fs_util.tests.cc
+ humanize.file_size.tests.cc
+ humanize.network.tests.cc
+ humanize.time.tests.cc
+ intern_string.tests.cc
+ lnav.gzip.tests.cc
+ string_util.tests.cc
+ network.tcp.tests.cc
+ test_base.cc)
+target_include_directories(test_base PUBLIC ../third-party/doctest-root)
+target_link_libraries(test_base base pcrepp ZLIB::ZLIB)
+add_test(NAME test_base COMMAND test_base)