summaryrefslogtreecommitdiffstats
path: root/plugin/provider_lzo
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 18:00:34 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 18:00:34 +0000
commit3f619478f796eddbba6e39502fe941b285dd97b1 (patch)
treee2c7b5777f728320e5b5542b6213fd3591ba51e2 /plugin/provider_lzo
parentInitial commit. (diff)
downloadmariadb-upstream.tar.xz
mariadb-upstream.zip
Adding upstream version 1:10.11.6.upstream/1%10.11.6upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--plugin/provider_lzo/CMakeLists.txt15
-rw-r--r--plugin/provider_lzo/plugin.c55
-rw-r--r--plugin/provider_lzo/provider_lzo.cnf3
3 files changed, 73 insertions, 0 deletions
diff --git a/plugin/provider_lzo/CMakeLists.txt b/plugin/provider_lzo/CMakeLists.txt
new file mode 100644
index 00000000..8a8d31d2
--- /dev/null
+++ b/plugin/provider_lzo/CMakeLists.txt
@@ -0,0 +1,15 @@
+FIND_PACKAGE(LZO)
+
+SET(CPACK_RPM_provider-lzo_PACKAGE_SUMMARY "LZO compression support in the server and storage engines" PARENT_SCOPE)
+SET(CPACK_RPM_provider-lzo_PACKAGE_DESCRIPTION "LZO compression support in the server and storage engines" PARENT_SCOPE)
+
+IF (LZO_FOUND)
+ GET_PROPERTY(dirs DIRECTORY PROPERTY INCLUDE_DIRECTORIES)
+ LIST(REMOVE_ITEM dirs ${CMAKE_SOURCE_DIR}/include/providers)
+ SET_PROPERTY(DIRECTORY PROPERTY INCLUDE_DIRECTORIES "${dirs}")
+
+ INCLUDE_DIRECTORIES(${LZO_INCLUDE_DIRS})
+
+ MYSQL_ADD_PLUGIN(provider_lzo plugin.c COMPONENT provider-lzo
+ LINK_LIBRARIES ${LZO_LIBRARIES} CONFIG provider_lzo.cnf)
+ENDIF()
diff --git a/plugin/provider_lzo/plugin.c b/plugin/provider_lzo/plugin.c
new file mode 100644
index 00000000..44c6b541
--- /dev/null
+++ b/plugin/provider_lzo/plugin.c
@@ -0,0 +1,55 @@
+/* Copyright (c) 2021, MariaDB Corporation
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; version 2 of the License.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1335 USA */
+
+#include <stdbool.h>
+#include <mysql_version.h>
+#include <mysql/plugin.h>
+#include <lzo/lzo1x.h>
+#include <providers/lzo/lzo1x.h>
+
+static int init(void* h)
+{
+ provider_service_lzo->lzo1x_1_15_compress_ptr= lzo1x_1_15_compress;
+ provider_service_lzo->lzo1x_decompress_safe_ptr= lzo1x_decompress_safe;
+
+ provider_service_lzo->is_loaded = true;
+
+ return 0;
+}
+
+static int deinit(void *h)
+{
+ return 1; /* don't unload me */
+}
+
+static struct st_mysql_daemon info= { MYSQL_DAEMON_INTERFACE_VERSION };
+
+maria_declare_plugin(provider_lzo)
+{
+ MYSQL_DAEMON_PLUGIN,
+ &info,
+ "provider_lzo",
+ "Kartik Soneji",
+ "LZO compression provider",
+ PLUGIN_LICENSE_GPL,
+ init,
+ deinit,
+ 0x0100,
+ NULL,
+ NULL,
+ "1.0",
+ MariaDB_PLUGIN_MATURITY_STABLE
+}
+maria_declare_plugin_end;
diff --git a/plugin/provider_lzo/provider_lzo.cnf b/plugin/provider_lzo/provider_lzo.cnf
new file mode 100644
index 00000000..65801983
--- /dev/null
+++ b/plugin/provider_lzo/provider_lzo.cnf
@@ -0,0 +1,3 @@
+[server]
+plugin_load_add=provider_lzo
+provider_lzo=force_plus_permanent