summaryrefslogtreecommitdiffstats
path: root/plugin/provider_bzip2
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/provider_bzip2')
-rw-r--r--plugin/provider_bzip2/CMakeLists.txt15
-rw-r--r--plugin/provider_bzip2/plugin.c61
-rw-r--r--plugin/provider_bzip2/provider_bzip2.cnf3
3 files changed, 79 insertions, 0 deletions
diff --git a/plugin/provider_bzip2/CMakeLists.txt b/plugin/provider_bzip2/CMakeLists.txt
new file mode 100644
index 00000000..e2ac4592
--- /dev/null
+++ b/plugin/provider_bzip2/CMakeLists.txt
@@ -0,0 +1,15 @@
+FIND_PACKAGE(BZip2)
+
+SET(CPACK_RPM_provider-bzip2_PACKAGE_SUMMARY "BZip2 compression support in the server and storage engines" PARENT_SCOPE)
+SET(CPACK_RPM_provider-bzip2_PACKAGE_DESCRIPTION "BZip2 compression support in the server and storage engines" PARENT_SCOPE)
+
+IF (BZIP2_FOUND)
+ GET_PROPERTY(dirs DIRECTORY PROPERTY INCLUDE_DIRECTORIES)
+ LIST(REMOVE_ITEM dirs ${CMAKE_SOURCE_DIR}/include/providers)
+ SET_PROPERTY(DIRECTORY PROPERTY INCLUDE_DIRECTORIES "${dirs}")
+
+ INCLUDE_DIRECTORIES(${BZIP2_INCLUDE_DIRS})
+
+ MYSQL_ADD_PLUGIN(provider_bzip2 plugin.c COMPONENT provider-bzip2
+ LINK_LIBRARIES ${BZIP2_LIBRARIES} CONFIG provider_bzip2.cnf)
+ENDIF()
diff --git a/plugin/provider_bzip2/plugin.c b/plugin/provider_bzip2/plugin.c
new file mode 100644
index 00000000..92978b7e
--- /dev/null
+++ b/plugin/provider_bzip2/plugin.c
@@ -0,0 +1,61 @@
+/* Copyright (c) 2021, MariaDB Corporation
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; version 2 of the License.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1335 USA */
+
+#include <stdbool.h>
+#include <mysql_version.h>
+#include <mysql/plugin.h>
+#include <bzlib.h>
+#include <providers/bzlib.h>
+
+static int init(void* h)
+{
+ provider_service_bzip2->BZ2_bzBuffToBuffCompress_ptr= BZ2_bzBuffToBuffCompress;
+ provider_service_bzip2->BZ2_bzBuffToBuffDecompress_ptr= BZ2_bzBuffToBuffDecompress;
+ provider_service_bzip2->BZ2_bzCompress_ptr= BZ2_bzCompress;
+ provider_service_bzip2->BZ2_bzCompressEnd_ptr= BZ2_bzCompressEnd;
+ provider_service_bzip2->BZ2_bzCompressInit_ptr= BZ2_bzCompressInit;
+ provider_service_bzip2->BZ2_bzDecompress_ptr= BZ2_bzDecompress;
+ provider_service_bzip2->BZ2_bzDecompressEnd_ptr= BZ2_bzDecompressEnd;
+ provider_service_bzip2->BZ2_bzDecompressInit_ptr= BZ2_bzDecompressInit;
+
+ provider_service_bzip2->is_loaded = true;
+
+ return 0;
+}
+
+static int deinit(void *h)
+{
+ return 1; /* don't unload me */
+}
+
+static struct st_mysql_daemon info= { MYSQL_DAEMON_INTERFACE_VERSION };
+
+maria_declare_plugin(provider_bzip2)
+{
+ MYSQL_DAEMON_PLUGIN,
+ &info,
+ "provider_bzip2",
+ "Kartik Soneji",
+ "BZip2 compression provider",
+ PLUGIN_LICENSE_GPL,
+ init,
+ deinit,
+ 0x0100,
+ NULL,
+ NULL,
+ "1.0",
+ MariaDB_PLUGIN_MATURITY_STABLE
+}
+maria_declare_plugin_end;
diff --git a/plugin/provider_bzip2/provider_bzip2.cnf b/plugin/provider_bzip2/provider_bzip2.cnf
new file mode 100644
index 00000000..9b855e88
--- /dev/null
+++ b/plugin/provider_bzip2/provider_bzip2.cnf
@@ -0,0 +1,3 @@
+[server]
+plugin_load_add=provider_bzip2
+provider_bzip2=force_plus_permanent