summaryrefslogtreecommitdiffstats
path: root/src/editor/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 17:44:12 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 17:44:12 +0000
commit8ccb487c21368a7fdc8c7c72315325bf0aa06147 (patch)
treeb2056fae01d325924508a41731edfbd4c3cddd23 /src/editor/Makefile.am
parentInitial commit. (diff)
downloadmc-8ccb487c21368a7fdc8c7c72315325bf0aa06147.tar.xz
mc-8ccb487c21368a7fdc8c7c72315325bf0aa06147.zip
Adding upstream version 3:4.8.29.upstream/3%4.8.29upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/editor/Makefile.am')
-rw-r--r--src/editor/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/editor/Makefile.am b/src/editor/Makefile.am
new file mode 100644
index 0000000..5741959
--- /dev/null
+++ b/src/editor/Makefile.am
@@ -0,0 +1,33 @@
+EXTRA_DIST =
+
+if USE_INTERNAL_EDIT
+noinst_LTLIBRARIES = libedit.la
+else
+noinst_LTLIBRARIES =
+endif
+
+libedit_la_SOURCES = \
+ bookmark.c \
+ edit-impl.h \
+ edit.c edit.h \
+ editcomplete.c editcomplete.h \
+ editbuffer.c editbuffer.h \
+ editcmd.c \
+ editdraw.c \
+ editmacros.c editmacros.h \
+ editmenu.c \
+ editoptions.c \
+ editsearch.c editsearch.h \
+ editwidget.c editwidget.h \
+ etags.c etags.h \
+ format.c \
+ syntax.c
+
+if USE_ASPELL
+if HAVE_GMODULE
+libedit_la_SOURCES += \
+ spell.c spell.h
+endif
+endif
+
+AM_CPPFLAGS = $(GLIB_CFLAGS) -I$(top_srcdir) $(PCRE_CPPFLAGS)