summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:39 +0000
commit289262a517ab91e32d5982dee4c1cdc9c9d7e75a (patch)
tree4fec5a9696c211c3e5cc570327077f5ba290b6d4 /debian/rules
parentAdding upstream version 1.0.1. (diff)
downloadmeson-289262a517ab91e32d5982dee4c1cdc9c9d7e75a.tar.xz
meson-289262a517ab91e32d5982dee4c1cdc9c9d7e75a.zip
Adding debian version 1.0.1-5.debian/1.0.1-5debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..38d4334
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+
+# Print all logging info to stdout so it
+# shows up in build logs.
+export MESON_PRINT_TEST_OUTPUT=1
+
+export QT_SELECT=qt5
+
+# We're not in 1963 anymore, Toto!
+export LC_ALL=C.UTF-8
+
+export PYBUILD_NAME=meson
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild --with bash-completion
+
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+override_dh_auto_test:
+ ./run_tests.py
+endif