summaryrefslogtreecommitdiffstats
path: root/manual tests/5 rpm
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /manual tests/5 rpm
parentInitial commit. (diff)
downloadmeson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.tar.xz
meson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--manual tests/5 rpm/lib.c6
-rw-r--r--manual tests/5 rpm/lib.h1
-rw-r--r--manual tests/5 rpm/main.c8
-rw-r--r--manual tests/5 rpm/meson.build14
4 files changed, 29 insertions, 0 deletions
diff --git a/manual tests/5 rpm/lib.c b/manual tests/5 rpm/lib.c
new file mode 100644
index 0000000..efc230a
--- /dev/null
+++ b/manual tests/5 rpm/lib.c
@@ -0,0 +1,6 @@
+#include"lib.h"
+
+char *meson_print(void)
+{
+ return "Hello, world!";
+}
diff --git a/manual tests/5 rpm/lib.h b/manual tests/5 rpm/lib.h
new file mode 100644
index 0000000..08fc961
--- /dev/null
+++ b/manual tests/5 rpm/lib.h
@@ -0,0 +1 @@
+char *meson_print(void);
diff --git a/manual tests/5 rpm/main.c b/manual tests/5 rpm/main.c
new file mode 100644
index 0000000..8b1d193
--- /dev/null
+++ b/manual tests/5 rpm/main.c
@@ -0,0 +1,8 @@
+#include<lib.h>
+#include<stdio.h>
+int main(void)
+{
+ char *t = meson_print();
+ printf("%s", t);
+ return 0;
+}
diff --git a/manual tests/5 rpm/meson.build b/manual tests/5 rpm/meson.build
new file mode 100644
index 0000000..131da39
--- /dev/null
+++ b/manual tests/5 rpm/meson.build
@@ -0,0 +1,14 @@
+project('test spec', 'c')
+
+rpm = import('rpm')
+dependency('zlib')
+find_program('nonexistprog', required : false)
+
+lib = shared_library('mesontest_shared', ['lib.c', 'lib.h'],
+ version : '0.1', soversion : '0',
+ install : true)
+executable('mesontest-bin', 'main.c',
+ link_with : lib,
+ install : true)
+
+rpm.generate_spec_template()