summaryrefslogtreecommitdiffstats
path: root/manual tests/6 hg wrap
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /manual tests/6 hg wrap
parentInitial commit. (diff)
downloadmeson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.tar.xz
meson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'manual tests/6 hg wrap')
-rw-r--r--manual tests/6 hg wrap/meson.build10
-rw-r--r--manual tests/6 hg wrap/prog.c6
-rw-r--r--manual tests/6 hg wrap/subprojects/samplesubproject.wrap4
3 files changed, 20 insertions, 0 deletions
diff --git a/manual tests/6 hg wrap/meson.build b/manual tests/6 hg wrap/meson.build
new file mode 100644
index 0000000..c7ac004
--- /dev/null
+++ b/manual tests/6 hg wrap/meson.build
@@ -0,0 +1,10 @@
+project('Mercurial outcheckker', 'c')
+
+sp = subproject('samplesubproject')
+
+exe = executable('gitprog', 'prog.c',
+include_directories : sp.get_variable('subproj_inc'),
+link_with : sp.get_variable('subproj_lib'),
+)
+
+test('maintest', exe)
diff --git a/manual tests/6 hg wrap/prog.c b/manual tests/6 hg wrap/prog.c
new file mode 100644
index 0000000..6e2c4d8
--- /dev/null
+++ b/manual tests/6 hg wrap/prog.c
@@ -0,0 +1,6 @@
+#include"subproj.h"
+
+int main(void) {
+ subproj_function();
+ return 0;
+}
diff --git a/manual tests/6 hg wrap/subprojects/samplesubproject.wrap b/manual tests/6 hg wrap/subprojects/samplesubproject.wrap
new file mode 100644
index 0000000..6d3b3f2
--- /dev/null
+++ b/manual tests/6 hg wrap/subprojects/samplesubproject.wrap
@@ -0,0 +1,4 @@
+[wrap-hg]
+directory=samplesubproject
+url=https://bitbucket.org/jpakkane/samplesubproject
+revision=tip