summaryrefslogtreecommitdiffstats
path: root/manual tests/8 timeout
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /manual tests/8 timeout
parentInitial commit. (diff)
downloadmeson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.tar.xz
meson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--manual tests/8 timeout/meson.build8
-rw-r--r--manual tests/8 timeout/sleepprog.c6
2 files changed, 14 insertions, 0 deletions
diff --git a/manual tests/8 timeout/meson.build b/manual tests/8 timeout/meson.build
new file mode 100644
index 0000000..8ba7d4b
--- /dev/null
+++ b/manual tests/8 timeout/meson.build
@@ -0,0 +1,8 @@
+project('timeout', 'c')
+
+# This creates a test that times out. It is a manual test
+# because currently there is no test suite for test that are expected
+# to fail during unit test phase.
+
+exe = executable('sleepprog', 'sleepprog.c')
+test('timeout', exe, timeout : 1)
diff --git a/manual tests/8 timeout/sleepprog.c b/manual tests/8 timeout/sleepprog.c
new file mode 100644
index 0000000..8875e12
--- /dev/null
+++ b/manual tests/8 timeout/sleepprog.c
@@ -0,0 +1,6 @@
+#include<unistd.h>
+
+int main(void) {
+ sleep(1000);
+ return 0;
+}