summaryrefslogtreecommitdiffstats
path: root/test cases/common/149 dotinclude
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/common/149 dotinclude
parentInitial commit. (diff)
downloadmeson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.tar.xz
meson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--test cases/common/149 dotinclude/dotproc.c10
-rw-r--r--test cases/common/149 dotinclude/meson.build4
-rw-r--r--test cases/common/149 dotinclude/stdio.h6
3 files changed, 20 insertions, 0 deletions
diff --git a/test cases/common/149 dotinclude/dotproc.c b/test cases/common/149 dotinclude/dotproc.c
new file mode 100644
index 0000000..f48c330
--- /dev/null
+++ b/test cases/common/149 dotinclude/dotproc.c
@@ -0,0 +1,10 @@
+#include"stdio.h"
+
+#ifndef WRAPPER_INCLUDED
+#error The wrapper stdio.h was not included.
+#endif
+
+int main(void) {
+ printf("Eventually I got printed.\n");
+ return 0;
+}
diff --git a/test cases/common/149 dotinclude/meson.build b/test cases/common/149 dotinclude/meson.build
new file mode 100644
index 0000000..f094ba1
--- /dev/null
+++ b/test cases/common/149 dotinclude/meson.build
@@ -0,0 +1,4 @@
+project('dotinclude', 'c')
+
+executable('dotproc', 'dotproc.c',
+ implicit_include_directories : false)
diff --git a/test cases/common/149 dotinclude/stdio.h b/test cases/common/149 dotinclude/stdio.h
new file mode 100644
index 0000000..b6bd09f
--- /dev/null
+++ b/test cases/common/149 dotinclude/stdio.h
@@ -0,0 +1,6 @@
+// There is no #pragma once because we _want_ to cause an eternal loop
+// if this wrapper invokes itself.
+
+#define WRAPPER_INCLUDED
+
+#include<stdio.h>