summaryrefslogtreecommitdiffstats
path: root/test cases/common/21 target arg
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/common/21 target arg
parentInitial commit. (diff)
downloadmeson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.tar.xz
meson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test cases/common/21 target arg')
-rw-r--r--test cases/common/21 target arg/func.c9
-rw-r--r--test cases/common/21 target arg/func2.c9
-rw-r--r--test cases/common/21 target arg/meson.build9
-rw-r--r--test cases/common/21 target arg/prog.cc13
-rw-r--r--test cases/common/21 target arg/prog2.cc13
5 files changed, 53 insertions, 0 deletions
diff --git a/test cases/common/21 target arg/func.c b/test cases/common/21 target arg/func.c
new file mode 100644
index 0000000..8c0659e
--- /dev/null
+++ b/test cases/common/21 target arg/func.c
@@ -0,0 +1,9 @@
+#ifndef CTHING
+#error "Local argument not set"
+#endif
+
+#ifdef CPPTHING
+#error "Wrong local argument set"
+#endif
+
+int func(void) { return 0; }
diff --git a/test cases/common/21 target arg/func2.c b/test cases/common/21 target arg/func2.c
new file mode 100644
index 0000000..1897cf7
--- /dev/null
+++ b/test cases/common/21 target arg/func2.c
@@ -0,0 +1,9 @@
+#ifdef CTHING
+#error "Local C argument set in wrong target"
+#endif
+
+#ifdef CPPTHING
+#error "Local CPP argument set in wrong target"
+#endif
+
+int func(void) { return 0; }
diff --git a/test cases/common/21 target arg/meson.build b/test cases/common/21 target arg/meson.build
new file mode 100644
index 0000000..11ac006
--- /dev/null
+++ b/test cases/common/21 target arg/meson.build
@@ -0,0 +1,9 @@
+project('local arg test', 'cpp', 'c')
+
+exe1 = executable('prog', 'prog.cc', 'func.c', \
+c_args : '-DCTHING', \
+cpp_args : '-DCPPTHING')
+exe2 = executable('prog2', 'prog2.cc', 'func2.c')
+
+test('prog1', exe1)
+test('prog2', exe2)
diff --git a/test cases/common/21 target arg/prog.cc b/test cases/common/21 target arg/prog.cc
new file mode 100644
index 0000000..23028af
--- /dev/null
+++ b/test cases/common/21 target arg/prog.cc
@@ -0,0 +1,13 @@
+#ifdef CTHING
+#error "Wrong local argument set"
+#endif
+
+#ifndef CPPTHING
+#error "Local argument not set"
+#endif
+
+extern "C" int func();
+
+int main(void) {
+ return func();
+}
diff --git a/test cases/common/21 target arg/prog2.cc b/test cases/common/21 target arg/prog2.cc
new file mode 100644
index 0000000..e2ffe62
--- /dev/null
+++ b/test cases/common/21 target arg/prog2.cc
@@ -0,0 +1,13 @@
+#ifdef CTHING
+#error "Local C argument set in wrong target"
+#endif
+
+#ifdef CPPTHING
+#error "Local CPP argument set in wrong target"
+#endif
+
+extern "C" int func();
+
+int main(void) {
+ return func();
+}