summaryrefslogtreecommitdiffstats
path: root/test cases/common/228 custom_target source
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/common/228 custom_target source
parentInitial commit. (diff)
downloadmeson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.tar.xz
meson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test cases/common/228 custom_target source')
-rw-r--r--test cases/common/228 custom_target source/a0
-rw-r--r--test cases/common/228 custom_target source/meson.build5
-rw-r--r--test cases/common/228 custom_target source/x.py5
3 files changed, 10 insertions, 0 deletions
diff --git a/test cases/common/228 custom_target source/a b/test cases/common/228 custom_target source/a
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/test cases/common/228 custom_target source/a
diff --git a/test cases/common/228 custom_target source/meson.build b/test cases/common/228 custom_target source/meson.build
new file mode 100644
index 0000000..98b9d26
--- /dev/null
+++ b/test cases/common/228 custom_target source/meson.build
@@ -0,0 +1,5 @@
+project('a', ['c'])
+
+x = find_program('x.py')
+outs = custom_target('foo', output: ['x.c', 'y'], input: 'a', command: [x])
+executable('testprog', outs[0])
diff --git a/test cases/common/228 custom_target source/x.py b/test cases/common/228 custom_target source/x.py
new file mode 100644
index 0000000..12f40c8
--- /dev/null
+++ b/test cases/common/228 custom_target source/x.py
@@ -0,0 +1,5 @@
+#! /usr/bin/env python3
+with open('x.c', 'w') as f:
+ print('int main(void) { return 0; }', file=f)
+with open('y', 'w'):
+ pass