summaryrefslogtreecommitdiffstats
path: root/test cases/common/237 fstrings/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/common/237 fstrings/meson.build
parentInitial commit. (diff)
downloadmeson-upstream.tar.xz
meson-upstream.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--test cases/common/237 fstrings/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/test cases/common/237 fstrings/meson.build b/test cases/common/237 fstrings/meson.build
new file mode 100644
index 0000000..d686f6b
--- /dev/null
+++ b/test cases/common/237 fstrings/meson.build
@@ -0,0 +1,7 @@
+project('meson-test')
+
+n = 10
+m = 'bar'
+s = f'test @n@ string (@@n@@): @m@'
+
+assert(s == 'test 10 string (@10@): bar', 'Incorrect string formatting')