summaryrefslogtreecommitdiffstats
path: root/test cases/common/247 deprecated option/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/common/247 deprecated option/meson.build
parentInitial commit. (diff)
downloadmeson-abc1053c93e42d48e1bfeece27bb47e24257fdef.tar.xz
meson-abc1053c93e42d48e1bfeece27bb47e24257fdef.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test cases/common/247 deprecated option/meson.build')
-rw-r--r--test cases/common/247 deprecated option/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/test cases/common/247 deprecated option/meson.build b/test cases/common/247 deprecated option/meson.build
new file mode 100644
index 0000000..4c734ee
--- /dev/null
+++ b/test cases/common/247 deprecated option/meson.build
@@ -0,0 +1,20 @@
+project('deprecated options',
+ default_options: [
+ 'o1=false',
+ 'o2=a,b',
+ 'o3=a,b',
+ 'o4=true',
+ 'o5=auto',
+ 'o6=false',
+ 'o8=/foo',
+ ]
+)
+
+assert(get_option('o1') == false)
+assert(get_option('o2') == ['a', 'b'])
+assert(get_option('o3') == ['c', 'b'])
+assert(get_option('o4').enabled())
+assert(get_option('o5') == false)
+assert(get_option('o6') == false)
+assert(get_option('o7').disabled())
+assert(get_option('python.platlibdir') == '/foo')