summaryrefslogtreecommitdiffstats
path: root/test cases/common/83 identical target name in subproject/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/common/83 identical target name in subproject/meson.build
parentInitial commit. (diff)
downloadmeson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.tar.xz
meson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test cases/common/83 identical target name in subproject/meson.build')
-rw-r--r--test cases/common/83 identical target name in subproject/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/test cases/common/83 identical target name in subproject/meson.build b/test cases/common/83 identical target name in subproject/meson.build
new file mode 100644
index 0000000..64b4363
--- /dev/null
+++ b/test cases/common/83 identical target name in subproject/meson.build
@@ -0,0 +1,9 @@
+project('toplevel bar', 'c')
+
+subproject('foo')
+
+true_cmd = find_program('true.py')
+
+executable('bar', 'bar.c')
+run_target('nop', command : [true_cmd])
+custom_target('cus', output: ['cus.c'], command : [true_cmd])