summaryrefslogtreecommitdiffstats
path: root/test cases/common/99 postconf
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/common/99 postconf
parentInitial commit. (diff)
downloadmeson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.tar.xz
meson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test cases/common/99 postconf')
-rw-r--r--test cases/common/99 postconf/meson.build5
-rw-r--r--test cases/common/99 postconf/postconf.py16
-rw-r--r--test cases/common/99 postconf/prog.c5
-rw-r--r--test cases/common/99 postconf/raw.dat1
4 files changed, 27 insertions, 0 deletions
diff --git a/test cases/common/99 postconf/meson.build b/test cases/common/99 postconf/meson.build
new file mode 100644
index 0000000..12b3c5b
--- /dev/null
+++ b/test cases/common/99 postconf/meson.build
@@ -0,0 +1,5 @@
+project('postconf script', 'c')
+
+meson.add_postconf_script('postconf.py')
+
+test('post', executable('prog', 'prog.c'))
diff --git a/test cases/common/99 postconf/postconf.py b/test cases/common/99 postconf/postconf.py
new file mode 100644
index 0000000..950c706
--- /dev/null
+++ b/test cases/common/99 postconf/postconf.py
@@ -0,0 +1,16 @@
+#!/usr/bin/env python3
+
+import os
+
+template = '''#pragma once
+
+#define THE_NUMBER {}
+'''
+
+input_file = os.path.join(os.environ['MESON_SOURCE_ROOT'], 'raw.dat')
+output_file = os.path.join(os.environ['MESON_BUILD_ROOT'], 'generated.h')
+
+with open(input_file) as f:
+ data = f.readline().strip()
+with open(output_file, 'w') as f:
+ f.write(template.format(data))
diff --git a/test cases/common/99 postconf/prog.c b/test cases/common/99 postconf/prog.c
new file mode 100644
index 0000000..85a25a3
--- /dev/null
+++ b/test cases/common/99 postconf/prog.c
@@ -0,0 +1,5 @@
+#include"generated.h"
+
+int main(void) {
+ return THE_NUMBER != 9;
+}
diff --git a/test cases/common/99 postconf/raw.dat b/test cases/common/99 postconf/raw.dat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/test cases/common/99 postconf/raw.dat
@@ -0,0 +1 @@
+9