summaryrefslogtreecommitdiffstats
path: root/test cases/unit/34 command line
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/unit/34 command line
parentInitial commit. (diff)
downloadmeson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.tar.xz
meson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test cases/unit/34 command line')
-rw-r--r--test cases/unit/34 command line/meson.build9
-rw-r--r--test cases/unit/34 command line/meson_options.txt2
-rw-r--r--test cases/unit/34 command line/subprojects/subp/meson.build3
-rw-r--r--test cases/unit/34 command line/subprojects/subp/meson_options.txt1
4 files changed, 15 insertions, 0 deletions
diff --git a/test cases/unit/34 command line/meson.build b/test cases/unit/34 command line/meson.build
new file mode 100644
index 0000000..6207ca5
--- /dev/null
+++ b/test cases/unit/34 command line/meson.build
@@ -0,0 +1,9 @@
+project('command line test', 'c',
+ default_options : ['default_library=static', 'set_sub_opt=true']
+)
+
+if get_option('set_sub_opt')
+ subproject('subp', default_options : ['subp_opt=default3'])
+else
+ subproject('subp')
+endif
diff --git a/test cases/unit/34 command line/meson_options.txt b/test cases/unit/34 command line/meson_options.txt
new file mode 100644
index 0000000..244f570
--- /dev/null
+++ b/test cases/unit/34 command line/meson_options.txt
@@ -0,0 +1,2 @@
+option('set_sub_opt', type : 'boolean', value : false)
+option('set_percent_opt', type : 'string', value: 'not_set')
diff --git a/test cases/unit/34 command line/subprojects/subp/meson.build b/test cases/unit/34 command line/subprojects/subp/meson.build
new file mode 100644
index 0000000..cf79fa4
--- /dev/null
+++ b/test cases/unit/34 command line/subprojects/subp/meson.build
@@ -0,0 +1,3 @@
+project('subp',
+ default_options : ['subp_opt=default2']
+)
diff --git a/test cases/unit/34 command line/subprojects/subp/meson_options.txt b/test cases/unit/34 command line/subprojects/subp/meson_options.txt
new file mode 100644
index 0000000..8c50615
--- /dev/null
+++ b/test cases/unit/34 command line/subprojects/subp/meson_options.txt
@@ -0,0 +1 @@
+option('subp_opt', type : 'string', value : 'default1')