summaryrefslogtreecommitdiffstats
path: root/test cases/wasm/1 basic
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-29 04:41:38 +0000
commit7b6e527f440cd7e6f8be2b07cee320ee6ca18786 (patch)
tree4a2738d69fa2814659fdadddf5826282e73d81f4 /test cases/wasm/1 basic
parentInitial commit. (diff)
downloadmeson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.tar.xz
meson-7b6e527f440cd7e6f8be2b07cee320ee6ca18786.zip
Adding upstream version 1.0.1.upstream/1.0.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--test cases/wasm/1 basic/hello.c6
-rw-r--r--test cases/wasm/1 basic/hello.cpp6
-rw-r--r--test cases/wasm/1 basic/hello.html8
-rw-r--r--test cases/wasm/1 basic/meson.build4
4 files changed, 24 insertions, 0 deletions
diff --git a/test cases/wasm/1 basic/hello.c b/test cases/wasm/1 basic/hello.c
new file mode 100644
index 0000000..2328803
--- /dev/null
+++ b/test cases/wasm/1 basic/hello.c
@@ -0,0 +1,6 @@
+#include <stdio.h>
+
+int main() {
+ printf("Hello World\n");
+ return 0;
+}
diff --git a/test cases/wasm/1 basic/hello.cpp b/test cases/wasm/1 basic/hello.cpp
new file mode 100644
index 0000000..44b14ac
--- /dev/null
+++ b/test cases/wasm/1 basic/hello.cpp
@@ -0,0 +1,6 @@
+#include<iostream>
+
+int main(void) {
+ std::cout << "Hello World" << std::endl;
+ return 0;
+}
diff --git a/test cases/wasm/1 basic/hello.html b/test cases/wasm/1 basic/hello.html
new file mode 100644
index 0000000..637bc20
--- /dev/null
+++ b/test cases/wasm/1 basic/hello.html
@@ -0,0 +1,8 @@
+<html>
+ <head>
+ <meta charset="utf-8">
+ </head>
+ <body>
+ <script src="hello.js"></script>
+ </body>
+</html>
diff --git a/test cases/wasm/1 basic/meson.build b/test cases/wasm/1 basic/meson.build
new file mode 100644
index 0000000..1092a9b
--- /dev/null
+++ b/test cases/wasm/1 basic/meson.build
@@ -0,0 +1,4 @@
+project('emcctest', 'c', 'cpp')
+
+executable('hello-c', 'hello.c')
+executable('hello', 'hello.cpp')