summaryrefslogtreecommitdiffstats
path: root/manual tests/1 wrap/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--manual tests/1 wrap/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/manual tests/1 wrap/meson.build b/manual tests/1 wrap/meson.build
new file mode 100644
index 0000000..aee358d
--- /dev/null
+++ b/manual tests/1 wrap/meson.build
@@ -0,0 +1,13 @@
+project('downloader', 'c')
+
+cc = meson.get_compiler('c')
+
+s = subproject('sqlite').get_variable('sqlite_dep')
+th = dependency('threads')
+
+libdl = cc.find_library('dl', required : false)
+
+e = executable('dtest', 'main.c',
+ dependencies : [th, libdl, s])
+
+test('dltest', e)