summaryrefslogtreecommitdiffstats
path: root/manual tests/2 multiwrap/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--manual tests/2 multiwrap/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/manual tests/2 multiwrap/meson.build b/manual tests/2 multiwrap/meson.build
new file mode 100644
index 0000000..a4c42f4
--- /dev/null
+++ b/manual tests/2 multiwrap/meson.build
@@ -0,0 +1,12 @@
+project('multiwrap', 'c',
+ default_options : 'c_std=c99')
+
+# Using multiple downloaded projects for great justice.
+
+cc = meson.get_compiler('c')
+
+luadep = dependency('lua', fallback : ['lua', 'lua_dep'])
+pngdep = dependency('libpng', fallback : ['libpng', 'png_dep'])
+
+executable('prog', 'prog.c',
+ dependencies : [pngdep, luadep])