summaryrefslogtreecommitdiffstats
path: root/test cases/cmake/14 fortran threads
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test cases/cmake/14 fortran threads/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/test cases/cmake/14 fortran threads/meson.build b/test cases/cmake/14 fortran threads/meson.build
new file mode 100644
index 0000000..2d2f892
--- /dev/null
+++ b/test cases/cmake/14 fortran threads/meson.build
@@ -0,0 +1,12 @@
+project('FortranThreads')
+
+if not add_languages('fortran', required: false)
+ error('MESON_SKIP_TEST: Fortran language not available.')
+endif
+
+# want to be sure that CMake can find dependencies where even if the
+# project isn't C, the C language is required to find the library.
+threads = dependency('threads', method: 'cmake', required: false)
+if not threads.found()
+ error('MESON_SKIP_TEST: CMake backend not working for Fortran / threads')
+endif