summaryrefslogtreecommitdiffstats
path: root/test cases/common/101 testframework options/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test cases/common/101 testframework options/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/test cases/common/101 testframework options/meson.build b/test cases/common/101 testframework options/meson.build
new file mode 100644
index 0000000..4621b30
--- /dev/null
+++ b/test cases/common/101 testframework options/meson.build
@@ -0,0 +1,8 @@
+# normally run only from run_tests.py or run_project_tests.py
+# else do like
+# meson build '-Dtestoption=A string with spaces' -Dother_one=true -Dcombo_opt=one -Dprefix=/usr -Dlibdir=lib -Dbackend=ninja -Dwerror=True
+project('options')
+
+assert(get_option('testoption') == 'A string with spaces', 'Incorrect value for testoption option.')
+assert(get_option('other_one') == true, 'Incorrect value for other_one option.')
+assert(get_option('combo_opt') == 'one', 'Incorrect value for combo_opt option.')