summaryrefslogtreecommitdiffstats
path: root/test cases/common/13 pch/userDefined/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/13 pch/userDefined/meson.build')
-rw-r--r--test cases/common/13 pch/userDefined/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/test cases/common/13 pch/userDefined/meson.build b/test cases/common/13 pch/userDefined/meson.build
new file mode 100644
index 0000000..9b60572
--- /dev/null
+++ b/test cases/common/13 pch/userDefined/meson.build
@@ -0,0 +1,10 @@
+cc = meson.get_compiler('c')
+cc_id = cc.get_id()
+
+# User supplied PCH implementation should override the auto
+# generated one. PCH implementations are only supported for
+# msvc and generally should not be used at all. Support for
+# them is only kept for backwards compatibility.
+if cc_id == 'msvc'
+ exe = executable('prog', 'prog.c', c_pch : ['pch/pch.h', 'pch/pch.c'])
+endif