summaryrefslogtreecommitdiffstats
path: root/test cases/common/224 arithmetic operators/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/224 arithmetic operators/meson.build')
-rw-r--r--test cases/common/224 arithmetic operators/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/test cases/common/224 arithmetic operators/meson.build b/test cases/common/224 arithmetic operators/meson.build
new file mode 100644
index 0000000..a904bd0
--- /dev/null
+++ b/test cases/common/224 arithmetic operators/meson.build
@@ -0,0 +1,8 @@
+project('arithmetic operators')
+assert(5 - 3 - 1 == 1)
+assert(5 - (3 - 1) == 3)
+assert(5 - 1 * 3 - 3 == -1)
+assert(420 - 300 - 51 == 69)
+assert(1000 / 2 / 2 / 2 == 125)
+assert(4 * 9 / 3 % 8 - 3 - 10 / 2 == -4)
+assert(94 - 30 + (2 - (40 - 6 + 7) - 9) - 10 == 6)