summaryrefslogtreecommitdiffstats
path: root/test cases/common/226 link depends indexed custom target/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/226 link depends indexed custom target/meson.build')
-rw-r--r--test cases/common/226 link depends indexed custom target/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/test cases/common/226 link depends indexed custom target/meson.build b/test cases/common/226 link depends indexed custom target/meson.build
new file mode 100644
index 0000000..27f3a3f
--- /dev/null
+++ b/test cases/common/226 link depends indexed custom target/meson.build
@@ -0,0 +1,20 @@
+project('link_depends_indexed_custom_target', 'c')
+
+cmd = find_program('make_file.py')
+
+dep_files = custom_target('gen_dep',
+ command: [cmd, '@OUTPUT@'],
+ output: ['dep_file1', 'dep_file2'])
+
+exe = executable('foo', 'foo.c',
+ link_depends: dep_files[1],
+ c_args: ['-DDEPFILE="' + dep_files[0].full_path()+ '"'])
+
+check_arch = find_program('check_arch.py')
+custom_target('check-arch',
+ command: [check_arch, exe, host_machine.cpu_family(), '@OUTPUT@'],
+ build_by_default: true,
+ output: 'dummy.txt')
+
+# check that dep_file1 exists, which means that link_depends target ran
+test('runtest', exe)