summaryrefslogtreecommitdiffstats
path: root/test cases/common/23 endian/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test cases/common/23 endian/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/test cases/common/23 endian/meson.build b/test cases/common/23 endian/meson.build
new file mode 100644
index 0000000..80186fe
--- /dev/null
+++ b/test cases/common/23 endian/meson.build
@@ -0,0 +1,7 @@
+project('endian check', 'c')
+
+if host_machine.endian() == 'big'
+ add_global_arguments('-DIS_BE', language : 'c')
+endif
+
+test('endiantest', executable('prog', 'prog.c'))