summaryrefslogtreecommitdiffstats
path: root/test cases/common/249 install_symlink/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/249 install_symlink/meson.build')
-rw-r--r--test cases/common/249 install_symlink/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/test cases/common/249 install_symlink/meson.build b/test cases/common/249 install_symlink/meson.build
new file mode 100644
index 0000000..ae30382
--- /dev/null
+++ b/test cases/common/249 install_symlink/meson.build
@@ -0,0 +1,9 @@
+project('install_emptydir')
+
+if build_machine.system() == 'windows' and meson.backend() == 'ninja'
+ error('MESON_SKIP_TEST windows does not support symlinks unless root or in development mode')
+endif
+
+install_data('datafile.dat', install_dir: 'share/progname/C')
+install_symlink('datafile.dat', pointing_to: '../C/datafile.dat', install_dir: 'share/progname/es')
+install_symlink('rename_datafile.dat', pointing_to: '../C/datafile.dat', install_dir: 'share/progname/fr')