summaryrefslogtreecommitdiffstats
path: root/test cases/common/252 install data structured/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/252 install data structured/meson.build')
-rw-r--r--test cases/common/252 install data structured/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/test cases/common/252 install data structured/meson.build b/test cases/common/252 install data structured/meson.build
new file mode 100644
index 0000000..9d29794
--- /dev/null
+++ b/test cases/common/252 install data structured/meson.build
@@ -0,0 +1,16 @@
+project('install structured data')
+
+install_data(
+ 'dir1/file1',
+ 'dir1/file2',
+ 'dir1/file3',
+ 'dir2/file1',
+ 'dir2/file2',
+ 'dir2/file3',
+ 'dir3/file1',
+ 'dir3/file2',
+ 'dir3/file3',
+ install_dir: get_option('datadir'),
+ preserve_path: true,
+)
+subdir('pysrc')