summaryrefslogtreecommitdiffstats
path: root/test cases/common/3 static/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test cases/common/3 static/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/test cases/common/3 static/meson.build b/test cases/common/3 static/meson.build
new file mode 100644
index 0000000..04ff2f6
--- /dev/null
+++ b/test cases/common/3 static/meson.build
@@ -0,0 +1,14 @@
+project('static library test', 'c')
+
+lib = static_library('mylib', get_option('source'),
+ link_args : '-THISMUSTNOBEUSED') # Static linker needs to ignore all link args.
+assert(lib.name() == 'mylib')
+has_not_changed = false
+if is_disabler(lib)
+ has_not_changed = true
+else
+ has_not_changed = true
+endif
+assert(has_not_changed, 'Static library has changed.')
+
+assert(not is_disabler(lib), 'Static library is a disabler.')