summaryrefslogtreecommitdiffstats
path: root/test cases/common/63 array arithmetic/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test cases/common/63 array arithmetic/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/test cases/common/63 array arithmetic/meson.build b/test cases/common/63 array arithmetic/meson.build
new file mode 100644
index 0000000..7d5f54f
--- /dev/null
+++ b/test cases/common/63 array arithmetic/meson.build
@@ -0,0 +1,15 @@
+project('array arithmetic')
+
+array1 = ['foo', 'bar']
+array2 = ['qux', 'baz']
+
+if array1 + array2 != ['foo', 'bar', 'qux', 'baz']
+ error('Array concatenation is broken')
+endif
+if array2 + array1 != ['qux', 'baz', 'foo', 'bar']
+ error('Array concatenation is broken')
+endif
+
+if array1 + array1 + array1 != ['foo', 'bar', 'foo', 'bar', 'foo', 'bar']
+ error('Many-array concatenation is broken')
+endif