summaryrefslogtreecommitdiffstats
path: root/test cases/common/64 arithmetic bidmas/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/64 arithmetic bidmas/meson.build')
-rw-r--r--test cases/common/64 arithmetic bidmas/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/test cases/common/64 arithmetic bidmas/meson.build b/test cases/common/64 arithmetic bidmas/meson.build
new file mode 100644
index 0000000..548294b
--- /dev/null
+++ b/test cases/common/64 arithmetic bidmas/meson.build
@@ -0,0 +1,15 @@
+project('arithmetic bidmas')
+
+if 5 * 3 - 6 / 2 + 1 != 13
+ error('Arithmetic bidmas broken')
+endif
+if 5 * (3 - 6 / 2) + 1 != 1
+ error('Arithmetic bidmas with brackets broken')
+endif
+
+if 5 * 12 / 2 * 3 != 90
+ error('Sequential multiplication and division broken')
+endif
+if 5 * (12 / (2 * 3)) != 10
+ error('Sequential multiplication and division with brackets broken')
+endif