summaryrefslogtreecommitdiffstats
path: root/test cases/common/69 configure file in custom target/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/common/69 configure file in custom target/src/meson.build')
-rw-r--r--test cases/common/69 configure file in custom target/src/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/test cases/common/69 configure file in custom target/src/meson.build b/test cases/common/69 configure file in custom target/src/meson.build
new file mode 100644
index 0000000..e0ab9eb
--- /dev/null
+++ b/test cases/common/69 configure file in custom target/src/meson.build
@@ -0,0 +1,20 @@
+custom_target('thing',
+output : 'final.dat',
+input : cfile,
+command : [find_program('mycompiler.py'), '@INPUT@', '@OUTPUT@'])
+
+# Test usage of a `configure_file` as part of the command list
+py3 = find_program('python3', required : false)
+if not py3.found()
+ # Maybe 'python' is Python 3
+ py3 = find_program('python')
+endif
+
+compiler = configure_file(input : 'mycompiler.py',
+ output : 'mycompiler2.py',
+ copy: true)
+
+custom_target('thing2',
+output : 'final2.dat',
+input : cfile,
+command : [py3, compiler, '@INPUT@', '@OUTPUT@'])