summaryrefslogtreecommitdiffstats
path: root/test cases/common/75 custom subproject dir/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test cases/common/75 custom subproject dir/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/test cases/common/75 custom subproject dir/meson.build b/test cases/common/75 custom subproject dir/meson.build
new file mode 100644
index 0000000..d9ba649
--- /dev/null
+++ b/test cases/common/75 custom subproject dir/meson.build
@@ -0,0 +1,10 @@
+project('A', 'c', subproject_dir:'custom_subproject_dir')
+
+B = subproject('B')
+b = B.get_variable('b')
+
+C = subproject('C')
+c = C.get_variable('c')
+
+a = executable('a', 'a.c', link_with : [b, c])
+test('a test', a)