summaryrefslogtreecommitdiffstats
path: root/test cases/csharp/4 external dep/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test cases/csharp/4 external dep/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/test cases/csharp/4 external dep/meson.build b/test cases/csharp/4 external dep/meson.build
new file mode 100644
index 0000000..019d618
--- /dev/null
+++ b/test cases/csharp/4 external dep/meson.build
@@ -0,0 +1,9 @@
+project('C# external library', 'cs')
+glib_sharp_2 = dependency('glib-sharp-2.0', required : false)
+
+if not glib_sharp_2.found()
+ error('MESON_SKIP_TEST glib# not found.')
+endif
+
+e = executable('prog', 'prog.cs', dependencies: glib_sharp_2, install : true)
+test('libtest', e, args: [join_paths(meson.current_source_dir(), 'hello.txt')])