summaryrefslogtreecommitdiffstats
path: root/test cases/d/5 mixed/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/d/5 mixed/meson.build')
-rw-r--r--test cases/d/5 mixed/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/test cases/d/5 mixed/meson.build b/test cases/d/5 mixed/meson.build
new file mode 100644
index 0000000..3dad66d
--- /dev/null
+++ b/test cases/d/5 mixed/meson.build
@@ -0,0 +1,9 @@
+project('Mixing C and D', 'd', 'c')
+
+ldyn = shared_library('stuff', 'libstuff.c', install : true)
+ed = executable('appdc_d', 'app.d', link_with : ldyn, install : true)
+test('linktest_cdyn', ed)
+
+lstatic = static_library('stuff', 'libstuff.c', install : true)
+es = executable('appdc_s', 'app.d', link_with : lstatic, install : true)
+test('linktest_cstatic', es)