summaryrefslogtreecommitdiffstats
path: root/test cases/failing/129 generator host binary/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/failing/129 generator host binary/meson.build')
-rw-r--r--test cases/failing/129 generator host binary/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/test cases/failing/129 generator host binary/meson.build b/test cases/failing/129 generator host binary/meson.build
new file mode 100644
index 0000000..fc1f9be
--- /dev/null
+++ b/test cases/failing/129 generator host binary/meson.build
@@ -0,0 +1,14 @@
+project('generator host binary no exe_wrapper')
+
+if meson.can_run_host_binaries()
+ error('MESON_SKIP_TEST: test requires that build machine cannot run host binaries')
+endif
+
+add_languages('c', native : false)
+
+exe = executable('exe', 'exe.c', native : false)
+
+gen = generator(exe, output : '@BASENAME@.c', arguments : ['@INPUT@', '@OUTPU@'])
+foo = gen.process('lib.in')
+
+library('foo', foo)