summaryrefslogtreecommitdiffstats
path: root/test cases/failing/16 extract from subproject/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test cases/failing/16 extract from subproject/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/test cases/failing/16 extract from subproject/meson.build b/test cases/failing/16 extract from subproject/meson.build
new file mode 100644
index 0000000..286aaa1
--- /dev/null
+++ b/test cases/failing/16 extract from subproject/meson.build
@@ -0,0 +1,9 @@
+project('extract subproject object', 'c')
+
+sub = subproject('sub_project')
+lib = sub.get_variable('lib')
+
+exe = executable('exe', 'main.c',
+ objects : lib.extract_objects('sub_lib.c'))
+
+test('extraction test', exe)