summaryrefslogtreecommitdiffstats
path: root/test cases/failing/27 noprog use
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test cases/failing/27 noprog use/meson.build9
-rw-r--r--test cases/failing/27 noprog use/test.json7
2 files changed, 16 insertions, 0 deletions
diff --git a/test cases/failing/27 noprog use/meson.build b/test cases/failing/27 noprog use/meson.build
new file mode 100644
index 0000000..af31ece
--- /dev/null
+++ b/test cases/failing/27 noprog use/meson.build
@@ -0,0 +1,9 @@
+project('using not found exe')
+
+nope = find_program('nonexisting', required : false)
+
+custom_target( 'aa',
+ input: 'meson.build',
+ output: 'foobar',
+ command: [nope, '@INPUT@', '@OUTPUT@']
+)
diff --git a/test cases/failing/27 noprog use/test.json b/test cases/failing/27 noprog use/test.json
new file mode 100644
index 0000000..b84562e
--- /dev/null
+++ b/test cases/failing/27 noprog use/test.json
@@ -0,0 +1,7 @@
+{
+ "stdout": [
+ {
+ "line": "test cases/failing/27 noprog use/meson.build:5:0: ERROR: Tried to use not-found external program in \"command\""
+ }
+ ]
+}