summaryrefslogtreecommitdiffstats
path: root/test cases/failing/74 link with shared module on osx/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test cases/failing/74 link with shared module on osx/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/test cases/failing/74 link with shared module on osx/meson.build b/test cases/failing/74 link with shared module on osx/meson.build
new file mode 100644
index 0000000..bf18b36
--- /dev/null
+++ b/test cases/failing/74 link with shared module on osx/meson.build
@@ -0,0 +1,8 @@
+project('link with shared module', 'c')
+
+if host_machine.system() != 'darwin'
+ error('MESON_SKIP_TEST test only fails on OSX')
+endif
+
+m = shared_module('mymodule', 'module.c')
+e = executable('prog', 'prog.c', link_with : m)