summaryrefslogtreecommitdiffstats
path: root/test cases/failing/96 no native compiler
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test cases/failing/96 no native compiler/main.c3
-rw-r--r--test cases/failing/96 no native compiler/meson.build12
-rw-r--r--test cases/failing/96 no native compiler/test.json7
3 files changed, 22 insertions, 0 deletions
diff --git a/test cases/failing/96 no native compiler/main.c b/test cases/failing/96 no native compiler/main.c
new file mode 100644
index 0000000..9b6bdc2
--- /dev/null
+++ b/test cases/failing/96 no native compiler/main.c
@@ -0,0 +1,3 @@
+int main(void) {
+ return 0;
+}
diff --git a/test cases/failing/96 no native compiler/meson.build b/test cases/failing/96 no native compiler/meson.build
new file mode 100644
index 0000000..f0126ac
--- /dev/null
+++ b/test cases/failing/96 no native compiler/meson.build
@@ -0,0 +1,12 @@
+project('no native compiler')
+
+if not meson.is_cross_build()
+ error('MESON_SKIP_TEST test only applicable when cross building.')
+endif
+
+if add_languages('c', required: false, native: true)
+ error('MESON_SKIP_TEST test only applicable when native compiler not available.')
+endif
+
+add_languages('c')
+executable('main', 'main.c', native: true)
diff --git a/test cases/failing/96 no native compiler/test.json b/test cases/failing/96 no native compiler/test.json
new file mode 100644
index 0000000..0107727
--- /dev/null
+++ b/test cases/failing/96 no native compiler/test.json
@@ -0,0 +1,7 @@
+{
+ "stdout": [
+ {
+ "line": "test cases/failing/96 no native compiler/meson.build:12:0: ERROR: No host machine compiler for \"main.c\""
+ }
+ ]
+}