summaryrefslogtreecommitdiffstats
path: root/test cases/fortran/12 submodule/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/fortran/12 submodule/meson.build')
-rw-r--r--test cases/fortran/12 submodule/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/test cases/fortran/12 submodule/meson.build b/test cases/fortran/12 submodule/meson.build
new file mode 100644
index 0000000..204a36b
--- /dev/null
+++ b/test cases/fortran/12 submodule/meson.build
@@ -0,0 +1,13 @@
+project('submodule single level', 'fortran',
+ meson_version: '>= 0.50.0')
+
+fortc = meson.get_compiler('fortran')
+if fortc.get_id() == 'gcc' and fortc.version().version_compare('<6.0')
+ error('MESON_SKIP_TEST need gfortran >= 6.0 for submodule support')
+endif
+
+hier2 = executable('single', 'parent.f90', 'child.f90')
+test('single-level hierarchy', hier2)
+
+hierN = executable('multi', 'a1.f90', 'a2.f90', 'a3.f90')
+test('multi-level hierarchy', hierN)