summaryrefslogtreecommitdiffstats
path: root/test cases/fortran/5 static
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--test cases/fortran/5 static/main.f906
-rw-r--r--test cases/fortran/5 static/meson.build6
-rw-r--r--test cases/fortran/5 static/static_hello.f9017
3 files changed, 29 insertions, 0 deletions
diff --git a/test cases/fortran/5 static/main.f90 b/test cases/fortran/5 static/main.f90
new file mode 100644
index 0000000..4db2861
--- /dev/null
+++ b/test cases/fortran/5 static/main.f90
@@ -0,0 +1,6 @@
+program main
+use static_hello
+implicit none
+
+call static_say_hello()
+end program
diff --git a/test cases/fortran/5 static/meson.build b/test cases/fortran/5 static/meson.build
new file mode 100644
index 0000000..ab9d3c4
--- /dev/null
+++ b/test cases/fortran/5 static/meson.build
@@ -0,0 +1,6 @@
+project('try-static-library', 'fortran')
+
+static_hello = static_library('static_hello', 'static_hello.f90')
+
+exe = executable('test_exe', 'main.f90', link_with : static_hello)
+test('static-fortran', exe)
diff --git a/test cases/fortran/5 static/static_hello.f90 b/test cases/fortran/5 static/static_hello.f90
new file mode 100644
index 0000000..5407560
--- /dev/null
+++ b/test cases/fortran/5 static/static_hello.f90
@@ -0,0 +1,17 @@
+module static_hello
+implicit none
+
+private
+public :: static_say_hello
+
+interface static_say_hello
+ module procedure say_hello
+end interface static_say_hello
+
+contains
+
+subroutine say_hello
+ print *, "Static library called."
+end subroutine say_hello
+
+end module static_hello