summaryrefslogtreecommitdiffstats
path: root/test cases/frameworks/29 blocks/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/frameworks/29 blocks/meson.build')
-rw-r--r--test cases/frameworks/29 blocks/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/test cases/frameworks/29 blocks/meson.build b/test cases/frameworks/29 blocks/meson.build
new file mode 100644
index 0000000..398c92c
--- /dev/null
+++ b/test cases/frameworks/29 blocks/meson.build
@@ -0,0 +1,12 @@
+project('blocks-dependency', 'c')
+
+id = meson.get_compiler('c').get_id()
+if id != 'clang' or build_machine.system() == 'windows'
+ error('MESON_SKIP_TEST: Only clang on unix-like systems supports the blocks extension.')
+endif
+
+exe = executable('main', 'main.c',
+ dependencies: dependency('blocks')
+)
+
+test('test-blocks', exe)